Internet Explorer Back button not working

Posted by Unknown Posted on Sunday, September 23, 2012

This issue could be because of any corruption in the add-ons or Internet explorer settings. Follow the below steps to resolve the issue.


Method 1: Disable Add-ons using Divide and Conquer method:


  1. Click Start -> All Programs -> Accessories -> System Tools -> Open Internet Explorer (No add-ons)
  2. Click on Tools, select Manage Add-ons and   Click Toolbars and Extensions (Under Show: click All add-ons)
  3. Then click any add-on and press CTRL + A on your keyboard (this should select all add-ons) and Click Disable all
  4. Close Internet Explorer (No add-ons) and Open Internet Explorer  
Now all add-ons are disabled in Internet Explorer, test the back button and see whether the issue is resolved. If you did not see any problem then the next step is to enable the add-ons one by one to find which causes this to happen
  1. Open Internet Explorer and click on Tools
  2. Select Manage Add-ons and click the first disabled add-on
  3. Click Enable and test the Internet Explorer
Similarly enable other add-ons one by one and test to see if the problem has returned. If you did find any corrupted add-on, delete or disable it permanently.   

Method 2: Repair or Reinstall Internet Explorer


First of all try to reset the Internet explorer to the default settings; it may help to solve most of the problems with Internet Explorer and if it did not resolve your problem try to re install the Internet Explorer.

How to reinstall or repair Internet Explorer in Windows 7, Windows Vista, and Windows XP
http://support.microsoft.com/kb/318378

Feel free to comment, if you required more assistance.